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Lab 1.1 
Software and Data Storage 

Even if you have used computer programs before, you probably have not stopped to 
consider how the computer runs programs.  This lab will help you better understand the 
basic computing tasks of running programs and storing data on disk.  Throughout the lab, 
we will be using a great deal of vocabulary introduced in Chapter 1 (Terms of 
Endearment).  While the procedure is specific to Microsoft Windows, most of the 
concepts are about computing in general.  The concepts and vocabulary in this lab are 
fundamental and will be revisited extensively in future labs. 

Vocabulary 

All key vocabulary used in this lab are listed below, with closely related words listed 
together: 

software, program 
text editor 
disk drive, hard disk, floppy disk 
RAM 
virtual memory vs. physical memory 
processor 
file, folder/directory 
hierarchy 
filename, pathname 
file properties 
byte, kilobyte, megabyte, gigabyte 
format, extension 
icon 
dialog box, window, minimize 

Post-lab Questions 

Write your answers after completing the lab, but read them carefully now and keep them 
in mind during the lab. 

1. Computers are unique in that they are general-purpose devices.  In other words, 
they were not designed for a very specific purpose, the way a watch is designed to 
keep time and a dictionary is designed to provide definitions.  As it turns out, 
however, computers can certainly both keep time and provide dictionary 
definitions.  Name three other special-purpose devices or objects (not necessarily 
electronic) which do things that computers can also do with the appropriate 
software and/or hardware. 
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2. RAM and hard disks are both forms of data storage.  How are they alike?  How 
are they different?  In particular, discuss the relative advantages and 
disadvantages of each. 
 
 

3. Describe at least one non-computing example of hierarchical organization in the 
real world—something like the geography example given in the lab. 
 
 

Discussion and Procedure 

Part 1. Running Software 

A computer without software is a doorstop.  A VCR and TV are useful only with tapes 
of movies or television shows to play on them.  A stereo system is only useful with CDs, 
records or tapes to play on them.  Similarly, software (a collective term for computer 
programs or “applications”) makes computers useful to us.  By running different 
programs, we can use computers for a surprisingly wide variety of purposes, from writing 
reports to modifying photographs.  In order to use computing effectively, you need to 
know what kinds of software is available and what tasks each is suitable for.  The table 
below lists a few common kinds of software and describes what they are useful for. 

  
kind of 
software 

what it’s for example products 

spreadsheet calculations and analysis on tables of 
numerical data, e.g., tracking personal 
expenses, data from scientific experiments 

Microsoft Excel, Lotus 1-
2-3, Corel Quattro Pro 

word processor editing and formatting documents, e.g., 
letters, essays, resumes 

Microsoft Word, Corel 
WordPerfect 

database storing and extracting structured 
information, e.g., on-line library catalog 

Oracle, IBM DB2, 
Microsoft SQLServer 

image editing creating and modifying images, including 
computer-generated images, as well as 
photographs 

Corel CorelDRAW, 
Adobe Photoshop 

To begin this lab, we will run a very simple program, a text editor, which is useful for 
creating and editing text that does not require any special kinds of lettering or formatting.  
(Given this, a text editor is sufficient for writing a shopping list but not for writing a term 
paper with illustrations or some other complicated document.) 
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How does a computer run a program? A full explanation would require a whole book, 
so we will just discuss it at a high level here.  Recall that a program consists of 
instructions for the computer to execute—lots and lots of them.  Programs are usually 
kept stored on a hard disk, because unlike RAM, disk storage does not get erased when 
the computer is powered down.  (Disks are sometimes called “disk drives” or just 
“drives.”)  Disks are also less expensive per unit storage than RAM.  There is a catch, of 
course:  RAM is much faster than disk storage (by at least an order of magnitude), so 
when a program is run, the instructions are copied into RAM first, and the processor 
reads and executes instructions from there. 

All of this happens very quickly, and you cannot see RAM being used, but there are at 
least two ways you can tell a hard disk is being accessed on most PCs.  First, many PC 
cases have a small LED lamp that lights up when the disk is being accessed.  Second, 
many hard disks make a muffled jittering noise when active.  Watch and listen for these 
signs throughout the lab whenever the disk is being accessed. 

1. Run Notepad from the Start Menu.  In Windows, a common way of running a 
program is from the Start menu.  First, we will be using the Notepad program, 
usually found under Start \ Programs \ Accessories, where \ indicates a submenu 
level.  Your instructor will tell you if your PC is set up with Notepad in another 
location.  Run Notepad now, and if you are quick and attentive, you might notice 
the hard disk light go on and hear the disk access.  (Notepad is such a simple 
program that its size is very small, and the disk access might be over so quickly 
that you will miss it altogether.) 

ALTERNATIVE: Another way to run Notepad is to select Start \ Run..., then type 
notepad and press Enter or click OK.  (Note that this does not work with all 
programs.) In Windows, there is often more than one way to do most things, and 
this is just one example. 

2. Edit plain text with Notepad.  Type a few lines of text—maybe a list of your 
favorite foods.  Experiment with selecting text by dragging over it with the 
mouse—that is, hold down the mouse button and move the mouse over a region 
of text.  Using the various selections under the Edit menu, you can delete, cut, 
copy and paste selected text.  When you select text and do a copy, it will appear 
as if nothing has happened, but in the PC, the text you selected has been copied 
into RAM, and if you click somewhere else in the document and do a paste, a 
copy of the text you had selected will be placed there. 
 
Also try using the Undo option.  How many changes can you actually “undo” 
using this feature?  For example, delete some text, then type some more without 
using the backspace key.  What happens when you use undo? 
 
 
 
How about if you delete text, then type some more but use the backspace key?  
What happens when you undo now? 
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The document you currently have open in Notepad is stored only in RAM.  If the PC 
were suddenly powered off (by a blackout, for instance), your text would be lost.  In the 
next section, we will discuss disk storage, the solution to this problem.  You can save 
your text to a file on disk for long-term storage.  Before we actually do this, however, we 
need to discuss how disk storage is organized. 

Faking RAM with a hard disk.  You might have heard of virtual memory before and 
wondered how it differs from RAM.  Virtual memory is called “virtual” because it is not 
actually the same kind of memory as RAM, although it is used for the same purpose.  
Especially nowadays, when most PCs run several memory-intensive programs 
simultaneously, it is common to run out of RAM.  However, RAM is much more 
expensive than disk space, so some clever computer designers invented a scheme where a 
certain amount of hard disk space can be used as extra RAM, at the expense of speed, of 
course.  This special disk space, masquerading as extra RAM, is called virtual memory.  
Some people call RAM physical memory to distinguish it from virtual memory. 

Part 2. Files and File Folders 

Keep your data in a file.  Just like almost everything else in computing, the storage 
capacity of hard disks increases every year, and we did not have some way of organizing 
use of disk storage, we would not be able to take advantage of such large amounts of 
storage space.  The file is one basic unit for storing and organizing data on disk.  In 
normal English, “file” usually means a folder for holding papers.  When discussing data 
on computer disks, you should be aware that “file” is defined differently.  More precisely, 
a file does not contain multiple documents but is the data on disk storing a single 
document.   

Fight clutter with organizational structure.  However, even if you name files carefully 
so that you can quickly identify their contents, a collection of more than a couple dozen 
files will probably be difficult to maintain.  In real life offices, documents are not kept in 
one enormous pile but are divided by subject and stored in folders and filing cabinets.  
More generally, they are organized in a hierarchy, with multiple levels of categories and 
subcategories.  You might consider doing the same with your own documents, like in this 
example hierarchy: 
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hierarchy of folders for organizing document files 

We have already seen an example of hierarchical organization in the Start menu and its 
submenus.  Under Start, there are a number of different submenus, including Programs, 
Settings and Documents.  The Programs submenu leads to programs and more 
submenus, including Accessories. 

3. Find some commonly used programs in the Start menu.  Paint is a simple drawing 
and image editing program, Internet Explorer is a web browser, Windows 
Media Player lets you play music and video files, and Calculator is self-
explanatory.  Where are these programs located in the Start menu?  Notate 
locations as we did with Notepad above. 
 
Start \ Programs \ Accessories \ Notepad 
 
 

Hierarchical organization like this is very common in computing.  (See Chapter 5, 
Searching for Truth, for more discussion.)  In addition to disk storage and the Start menu, 
you will see it again in the context of networks and programming.  However, hierarchical 
organization is nothing new or specific to computing; there are many everyday examples, 
although you might not have ever used the word “hierarchical” to describe them.  The 
world’s geography, for example, is divided into continents; each of which is divided into 
one or more countries; each of which is divided into states, in the case of the U.S.  States 
can be further divided into counties, metropolitan areas, cities, and even named 
neighborhoods. 
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Other hierarchical organization schemes, such as the way some people try to categorize 
music, are not so well-defined but still can be useful at times.  What city and state your 
address is in is not really open to argument, but classifying music can be highly 
subjective—not only how a particular piece of music or artist should be categorized, but 
whether we should be categorizing music at all in the first place!  But back to 
computing...   

Keep your files in folders.  You can organize files on a disk hierarchically by using file 
folders (also called directories or just folders).  A directory is fundamentally different 
from a file in that a directory is a container for multiple files and other directories, rather 
than for the data for a single file.  They are called folders, because folders in real life 
serve a similar purpose.  That is, a folder itself is not a document you can read, but it 
holds documents and perhaps other folders inside it.  By grouping related files together 
and creating directories to store them in, you can make them easy to access for future use.  
You can further organize your files by putting these directories in other directories 
reflecting even larger categories.   

In Windows, there is a standard way of notating the location of a file on a disk.  First, the 
disk drive containing the file is identified with a letter.  By convention, drive letters A 
and B are used for floppy disk drives and C and D are usually used for hard disk drives.  
This example specifies the location of a plain text file called outline.txt:  

c:\documents\courses\music history\final paper\outline.txt 

A filename with its location completely specified like this is sometimes called a 
pathname. Think of “path” as the sequence of folders you need to open to get to the file, 
starting from the drive.  In this case, starting from drive C, you would have to open the 
documents folder, then courses inside that folder, then music history, then 
finally, final paper, where you would find the file outline.txt. 

4. Save your file.  From the File menu, select Save As....  This will bring up a dialog 
box that you can use to decide where (in what folder) to save the file and what to 
name it.  The dialog box opens with a particular 
folder and shows its contents  (both files and 
folders).  Click the Save in drop-down list to see 
what folders contain the current folder.  
 
If you want to save your file in a different folder, you can change folders.  
To enter a folder in the currently displayed folder, just double-click it.  To 
back out of a folder (to switch to the folder that contains it), click the Up One 
Level button, which has a folder marked with an arrow on it.  Choose a filename 
carefully before saving.  A good filename is concise but informative.  Certain 
characters, including \ and *, are not allowed in filenames.  Makes sure to write 
down the location of your file so that you can find it later. 

ALTERNATIVE:  If you know exactly where you want to save a file, you can simply 
type its name with its full location (like the example above for outline.txt).  
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Just as in the example, start with the drive letter, followed by a colon, and 
backslashes to separate names of folders.  (This is why backslashes are not 
allowed in filenames.) 

Part 3. File Properties 

We call characteristics of a file such as filename, size, and format file properties.  Now 
that you have saved your text file, let’s take a look at its properties. 

5. Locate the file in Explorer.  You will not be using Notepad to examine your file’s 
properties, but we will leave it open while we do, so do not close Notepad.  Just 
minimize the Notepad window instead by clicking the leftmost of the three buttons 
on the right end of the title bar.  Notepad will stay open but hidden, and you 
should see a button for it at the bottom of the screen in the taskbar.  
You can click this button to restore the Notepad window. 
 
Unless you saved your file on the Desktop, in which case it should be visible 
there, begin by opening (double-clicking) My Computer on the desktop.  Open 
the drive and open the folders containing your file.  To find the example file 
outline.txt, you would start by opening the C drive, then open folders work, 
courses, art history, etc. in succession. 

6. Examine your file’s properties.  Click the file to select it, then from the File menu, 
select Properties.  You will get a dialog box with lots of detailed information 
about your file, including the date and time it was last modified (sometimes called 
a “timestamp”).  Other commonly useful properties include the file’s size, 
measured in the standard unit of computer data storage, bytes.  One byte can store 
one character (e.g., one letter, digit or symbol) of plain text.  For example, it 
would take 8 bytes to store the word “computer” in a plain text file.  The byte is a 
rather small unit, so file sizes are often measured in kilobytes (KB for short), 
where 1 KB is roughly a thousand bytes, or megabytes (MB), where 1 MB is 
roughly a thousand kilobytes.  The capacity of PC hard disks today (2001) is 
typically measured in gigabytes (GB), approximately a thousand megabytes. 

ALTERNATIVE:  You can also right-click the file and select Properties or select the 
file and press Alt-Enter to bring up the Properties dialog box for a file. 

In the space below, write down the size of your text file in bytes, the time of its 
creation, the time of its last modification, and the time of its last access. 
 
 
 
 
 
NOTE:  Be careful not to change the Attributes settings of the file unless you 
understand what they do.  When in doubt, close the Properties dialog by clicking 
Cancel instead of OK, and your file should be left unchanged. 
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Capacity and value.  In August 2001, the top-of-the-line PCs could ship with up to an 
incredible 4 GB of RAM and almost 300 GB of hard disk capacity, well beyond what an 
average home user would really need for current software.  Price per MB varies widely 
with time and storage characteristics like speed and capacity, but hard disks were less 
than one cent per MB, while RAM was at least about ten cents per MB. 

Smaller, but bigger.  When IBM introduced 1 GB drives to the market in 1980, their 
product was refrigerator-sized, weighted 550 pounds, and cost $40,000.  In 2002, IBM’s 
Microdrive offered 1 GB of storage in a matchbook-sized package weighing less than an 
ounce for under $500. 

7. Modify the file and reexamine its properties. Close the Properties dialog, return to 
your Notepad window.  Think of a short word (any word will do) and type it into 
your file somewhere.  Count the number of characters you added to your file.  
(This is the number of letters in the word and maybe a space, if you added one.)  
Save your changes, then write down which properties among the ones you records 
above, if any, you predict will have changed. 
 
 
 
 
 
Check the properties.  Which ones have changed and to what values? 
 
 
 
 
 

8. Examine the properties of the hard disk on your PC.  In addition to files, folders 
and disks have properties in Windows.  How big is the hard disk on your 
computer, i.e., how much storage capacity does it offer?  How much of this 
storage space is being used?  You can find the answers to these questions by 
examining the hard disk’s properties. 
 
Open My Computer, select the hard disk (usually Drive C, with Drive D also 
present if there is a second hard disk), and open its Properties as in Step 6 above.  
What is the total storage capacity of this disk? 
 
 
How much of this is being used? 
 
 
Do not change any of the settings in the disk’s Properties window.  Click Cancel 
to close the window. 

Part 4. File Formats 
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Although all programs save their data on disks as files, they often store them in a special 
format, a way of encoding information.  (File format is also known as file type and is 
shown under this name in the Windows file Properties dialog.)  The simplest file format 
is plain text, the format that Notepad and other text editors use, and files of this type are 
conventionally named with the txt filename extension.  In Windows, every file format 
has a corresponding filename extension.  Each file is displayed with the icon (small 
image) associated with the program used for the file format, like the little spiral-bound 
notebook for Notepad.  Notepad cannot open word processor document files (for 
example, those in Microsoft Word format), because they are in a format different from 
plain text that includes data for text style, such as italicization and underlining, in 
addition to the text itself.  The table below lists some common file formats and their 
corresponding icons, as displayed on most standard Windows PCs. 
 
extension icon description 
txt 

 
plain text 

doc 
 

Microsoft Word document 

htm 
html  

web page (HTML source) 

pdf 

 
Portable Document Format (Adobe Acrobat) 

zip 

 
compressed set of files 

gif 

 
GIF image  

bmp 

 
Windows bitmap image 

Remember how we said programs are read from disk into RAM when they are run?  
Programs, just like all other data on disk, are stored as files, too, in their own format, with 
the exe extension.  (The “exe” is short for “executable,” since “execution” can be used 
to refer to the process of running a program.) 

9. Examine Notepad’s properties.  The Notepad program is stored as a file called 
notepad.exe and is usually located the computer’s hard disk (often drive C) in 
a special folder named Windows or WinNT, which contains lots of files essential 
to the operating system.  Find this file and check its properties.  What is the file 
format (type)?  How big is it?  When was it last accessed? 
 
 
 
NOTE:  Be careful with the files in the special Windows folder.  If you delete, 
rename, or move any of these files, your PC might not work properly.  Your lab 
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computer should be set up to prevent you from doing this, but your own computer 
at home might not have such safeguards in place. 

10. Create a WordPad document.  Run WordPad from the Start menu, under 
Accessories.  Type one word and save the document in the same folder you saved 
your text file.  (WordPad will save the file with extension .rtf.)  How many 
letters are in the word that you typed? 
 
 

11. Examine your WordPad document’s properties.  If you typed this same word in a 
plain text file, the resulting file would only take as many bytes as you counted 
letters.  However, as you will see, the WordPad file you just created is much 
bigger.  Find your file in Explorer and check its properties.  What is its size in 
bytes?  (Look for the size, not the “Size on disk.”) 
 
 

12. Open your WordPad document in Notepad.  This should immediately strike you 
as a strange thing to do.  Notepad does not “understand” the WordPad file format 
and as a result, you should not be able to edit your document using Notepad.  
However, a file is a file, and Notepad can be forced to open files whose format is 
not plain text.  You would not normally ever do this kind of thing, but hopefully, 
it will illustrate how file formats work. 
 
Run Notepad and select Open... from the File menu.  Open the folder where you 
saved your plain text and WordPad files.  Which of your two files do you see 
listed? 
 
 
Note that the File name entry has *.txt in it.  The * is a special character that 
takes the place of any text, so this means that all files in the current directory that 
end with txt are listed.  Try typing *.rtf in the entry and press Enter.  Which 
of your files do you see now? 
 
 
 
Now, type *.* in the entry.  With * both before and after the . (the period), this 
will match all files, regardless of their filename extension.  Now, which of your 
files do you see? 
 
 
 
Open your WordPad file and describe what you see.  Briefly describe what you 
see.  Do you see the word you typed into the WordPad file somewhere? 
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Close all applications before proceeding to the next section. 

Part 5. Managing Files and Directories 

Floppy disks are like slower, smaller hard disks, but they are still worthwhile, because 
they have the advantage of being removable and portable.  So far in this lab, we have 
discussed how to navigate directory hierarchies and save files, but we have not covered 
how to do basic tasks like creating directories and moving or copying files.  These tasks 
are essential for good storage “housekeeping”—for keeping your file storage organized. 

13. Create a directory on your floppy disk. Insert your floppy disk into the drive.  
Open My Computer on the Desktop and open the A drive.  (The A drive is the 
floppy drive on most PCs, but you might try B, if that does not work..)  From the 
File menu, select New..., then select Folder.  A new folder should appear with its 
tentative name selected, allowing you to type its name immediately.  Just press 
Enter for now and accept its name of New Folder. 

14. Rename your folder.  Change the folder’s name to Lab 1.1.  Click the folder to 
select it, and from the File menu, select Rename.  The folder’s name will become 
selected, so when you start typing the new name, the old one will be replaced.  
Both files and folders can be renamed in this way. 
 
ALTERNATIVES:  Click the folder to select it, then click the name of the folder 
once.  A third way of renaming a file is to right-click it, then select Rename.  

It turns out copying and moving files is a lot like copying and moving text in Notepad.  
Both operations start with selecting the file you want to work with, then you choose an 
operation from the Edit menu.  All of these instructions also apply to copying and 
moving folders, but we will work with files here, for simplicity. 

15. Copy your Notepad file to your folder.  Now that you have created a new folder 
on your floppy disk, let’s start copying the files you created into the folder.  To do 
this, open windows for both the source folder (where the file you want to copy is 
currently stored) and the destination folder (where you want to place the copy).  
In this case, the source folder is where you stored your Notepad file in Step 4 
above.  The destination folder is the “Lab 1.1” folder you just created. 
 
In the source folder window, select the Notepad file you want to copy by clicking 
it once.  From the Edit menu, choose Copy.  Again, it appears as though nothing 
has happened, but the PC has made a note of which file you currently have 
selected.  Switch to the destination folder window and from the Edit menu, 
choose Paste, and a copy of the file should be made there.  This is not the only 
way of copying files, but it is among the easier ways, and it parallels text editing, 
making it easy to remember. 
 
Go back to the source and destination folders to make sure the file was indeed 
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copied (rather than moved).  Without opening the files, how can you check to see 
that the files are indeed duplicates of each other? 
 
 

16. Move your WordPad file to your folder.  Moving a file is just like copying, except 
rather than start by taking a copy of the file with Copy from the Edit menu, you 
choose Cut.  Try moving your WordPad file from its current location to the Lab 
1.1 folder on your floppy disk.  Again, after you are done, double-check both 
source and destination folders, this time making sure that the file only exists in the 
destination folder. 

17. Delete the WordPad file.  We are all humans and make mistakes, so at some point 
in your computing career, you will accidentally delete a file.  To prepare for a 
situation like that, it is important to know some basic ways of recovering deleted 
files.  First, start by deleting your WordPad file from the Lab 1.1 folder on 
your floppy disk.  Select the file, then, from the File menu, choose Delete.  That 
was your only copy of the file, so it might seem irrecoverably lost, but we will 
next see that you can usually recover accidentally deleted files. 

18. Recover the WordPad file.  The easiest way to “undelete” a file only works if you 
immediately realize your mistake and do not do too many other file operations, 
like copying, moving or more deleting.  Let’s try that first.  Under the Edit menu, 
you should see an option called Undo Delete.  Choose that and the file should 
reappear in the folder, just as before your “accidental” delete. 
 
ALTERNATIVE:  The way Windows works, when you choose to delete a file, it 
usually does not actually get erased from the disk right away.  Instead, it goes to a 
special temporary storage folder called the Recycle Bin.  This folder is not in My 
Computer but is on the Desktop.  Try deleting your WordPad file once more and 
find it in the Recycle Bin.  You can move the deleted file from the Recycle Bin 
just as you would from any other source folder.  Recover the file by cutting and 
pasting it to your Lab 1.1 folder. 

Optional Additional Activities 
 

• Just as you can check the properties for a file, you can check the properties of a 
folder to find out how many files and subfolders are inside and how much storage 
is occupied by it. 

Further Reading 
 

• See http://www.sims.berkeley.edu/research/projects/how-
much-info/datapowers.html or do a web search for “data powers of ten” 
for an interesting list of data storage units and about how much each can hold.  For 
instance, the complete works of Shakespeare takes about 5 MB. 
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• Look ahead to Chapter 8 (Bits and the “Why” of Bytes) to find out more about data 
storage—specifically, the special representation computers use for storing 
characters. 

• RAM and disk storage differ in many more ways than are discussed here.  RAM 
stores data using electrical current, which is why it loses information when 
powered off.  Disk drives, on the other hand, store data magnetically on round 
platters (hence the name “disk”), and magnetism persists without power (just as 
with cassette tapes).  Read more about how each of these storage mechanisms 
works on the web at http://www.howstuffworks.com/hard-disk.htm 
and http://www.howstuffworks.com/ram.htm.  You will probably find 
it helpful to read Chapter 8 first. 

• In this lab, we only provide a very general overview of how computers store and 
execute programs.  You can look ahead to Chapter 9 (Following Instructions) to 
find out the more complicated details about programs, instructions, and how the 
various parts of the computer are involved in executing them. 


